Game reports

Incident Report for Kahoot

Resolved

The issue with accessing reports is resolved. All services are fully operational. Reports are being uploaded and will be made available to customers shortly
Posted Apr 07, 2026 - 18:53 CEST

Investigating

Some customers may experience delays in the delivery of reports. Our team is currently investigating. Please stay tuned to this page for further updates.
Posted Apr 07, 2026 - 18:31 CEST
This incident affected: Kahoot! (Kahoot! reports).