Discover page

Incident Report for Kahoot

Resolved

The issue with accessing the Discover-page is resolved. All services are fully operational.
Posted Mar 24, 2023 - 17:33 CET

Identified

Some customers may still experience disruption when accessing the Discover-page. Please use the search or click on the category tiles to find the the kahoot of your desire.

Our team is currently investigating and is working on a fix. Please stay tuned to this page for further updates.
Posted Mar 24, 2023 - 08:23 CET

Investigating

Kahoot games are not available straight from the Discover-page. Please use the search or click on the tiles to find the the kahoot of your desire. Please stay tuned to this page for further updates.
Posted Mar 23, 2023 - 13:29 CET
This incident affected: Kahoot! (Search Kahoot! games and courses, Create, host or play a Kahoot!).