Website - kahoot.com incident
Incident Report for Kahoot
Resolved
The issue with accessing kahoot.com is resolved. All services are fully operational.
Posted Jan 06, 2022 - 14:02 CET
Identified
Some customers may still experience kahoot.com to load slowly or that some pages are unavailable
Our team has identified the error and is working on a fix.
Please stay tuned to this page for further updates.
Posted Jan 06, 2022 - 14:01 CET
Investigating
Some customers may experience kahoot.com to load slowly or that some pages are unavailable.
Our team is currently investigating. Please stay tuned to this page for further updates.
Posted Jan 06, 2022 - 14:00 CET
This incident affected: Kahoot! (Website - kahoot.com).