Website - kahoot.com
Incident Report for Kahoot
Resolved
The issue with accessing kahoot.com is resolved. All services are fully operational.
Posted Oct 13, 2023 - 15:53 CEST
Investigating
Some customers may experience kahoot.com to load slowly or that some pages are unavailable. Our team is currently investigating. Please stay tuned to this page for further updates.
Posted Oct 13, 2023 - 12:26 CEST
This incident affected: Kahoot! (Website - kahoot.com).