Website - kahoot.com

Incident Report for Kahoot

Resolved

The issue with logging into kahoot.com is resolved. All services are fully operational.
Posted Sep 11, 2024 - 19:30 CEST

Investigating

Some customers may experience kahoot.com to load slowly or that some pages are unavailable. To be able to login to your account go to create.kahoot.it Our team is currently investigating. Please stay tuned to this page for further updates.
Posted Sep 11, 2024 - 18:50 CEST
This incident affected: Kahoot! (Kahoot! Login to an account).